Jump to content
tanknet.org

System 76 Darter Pro Blog


Recommended Posts

Got it yesterday on my 60th. Then the fun began, as I started to f**k with it. So here is what happened:

 

1) Booted it up, and everything worked great. Pop OS sucks. So I shut it down to begin the surgery.

2) Opened it up which was agonizing since to remove the bottom plate, you have to (gently) remove the keyboard(!) in order to get the bottom cover off. Finally managed to get the darn cover off without breaking anything, or fubaring the ribbon cables underneath the keyboard. Removed the three screws and flipped it back over. Removed the cover, pulled the 8gb stick of ram out, and inserted the two 16gb modules (32 gb yay!). Removed the WD Green 240 gb SATA SSD, and replaced it with a 500 gb Samsung 970 EVO Plus NvME drive. Reassemble.

3) Insert Mint 19.3 flash drive, power up.

4) Install Mint, seems ok, hmmmm no WiFi recognized, funny it was there under POP OS.

5) Reboot after installation of all updates, get a nag screen to recover Pop OS, slow boot. Mint finally comes up, no Wifi, at all. Walk upstairs and hook it up to ethernet, that works.

6) Install System 76 PPAs, reboot, get message NO OPERATING SYSTEM FOUND. Reboot, get same message.

7) Cuss

8) Make a POP OS 18.04 LTS flash drive, insert it, machine refuses to see it. No joy.

9) Cuss and rage quit.

10) Calm down, and make a POP OS 19.04 flash drive.

11) Insert it into the same USB port, no joy. Put it in another USB port, IT IS ALIVE!

12) Install Pop OS.

13) Update, learn rapidly that Gnome and especially POP OS version of Gnome SUCKS @SS. I HATE IT. I want my Mint back!!!!

14) Research- discover that I can install Cinnamon, so I do so. A normal desktop arrives, but I still want my Mint back, even though I have no wifi.

15) Boots really slowly for some reason. Maybe Coreboot?

 

Some positives: The keyboard is great. The build quality is really good, LOTs of ports.

Link to post
Share on other sites

Ok, I got it to work. I updated to Kernel 5.3, applied all updates, added the System 76 PPA, did updates, rebooted. It took two minutes to get to a log in screen, I thought it had hung completely, but eventually it got to log in, and what do you know the WiFi is working! That was painful. No other method got the WiFi working except to add the specific System 76 driver which is really weird. Now I am copying my stuff back to the computer. It does not like my external hard drive on one of the USB ports, but sees a flash drive...odd. This machine certainly has its quirks.

Link to post
Share on other sites

Update, so far so good. I noticed that the Kernel listed is not one supported by Mint, it is instead apparently a System 76 special Kernel mix. It shows 5.3.0-7629 where 5.3.0-40 is the highest supported under Mint. That might be one of the early issues, in the the Coreboot firmware wanted the System 76 flavor of the kernel. Battery life bounces up and down from a high of six hours shown, to a low of one hour depending on some unknown factor. Just surfing the net bounces it from three to five hours. At this point I have a very stable system.

Link to post
Share on other sites

I'm glad you got it working! :-)

Did you figure out how to get it into a more power-saving mode?

I wrote this script to force all of the cores on my new laptop into "powersave" mode (which throttles their clock speed to about 800MHz), which is perhaps heavy-handed but works okay for my purposes, so maybe you might find it useful:
http://ciar.org/h/pdown

And this one puts all of the cores back at their max performance setting:
http://ciar.org/h/pup

If you have perl installed (which you should already; I think it's a core package on Mint) then putting these scripts into /usr/local/bin and then setting them executable (sudo chmod +x /usr/local/bin/pup /usr/local/bin/pdown) should allow you to just type "sudo pup" or "sudo pdown" at any shell prompt to put your processor into high/low power mode.

If your DE is already doing things to try to tune system performance vs power draw, then it might stomp on these scripts' effects, but I doubt it would hurt anything.

Edited by TTK Ciar
Link to post
Share on other sites

I broke out the laptop to type this rather than the iPad: I installed TLP, and configured it which gained me about 2 to 2.5 hours extra battery (which is where the change came about). I'll look into pup, it sounds good. I am going to go through five or six recharge/usage cycles to get a baseline on this system. It is still only on its second charge cycle. Some other observations:

 

1) Screen:really nice, lots of real estate, good 1080p, normal refresh rate for a laptop, Not quite as nice as the little HP which had an amazing screen, but still very nice.

2) Keyboard, nice but its hard to judge because my typing sucks.

3) Stability: Well so far so good, it is running Mint really nicely with the System 76 PPAs installed.

4) Some wonkiness with the USB ports. After i remove a drive, and try and plug a different one in, the USB does not "see" the drive, I have to plug it into a different USB port to get the drive seen. I eject the drive properly rather than just pull it out. So there is no USB-intteruptus :) .

5) Weight- really nice and light.

6) Processor seems to tick along at 2-5% when I am just surfing the net.

7) Touchpad woes: If I am doing any typing I have to turn off the d@mn touchpad otherwise I get random jumps, erases, and such due to my typing style. Not as critical as it could be since I use an external mouse. I also have to remove my watch since the band keeps scraping the laptop.

8) Mint/Cinnamon works for me, it gives me a familiar workflow while being unobtrusive compared to the mind blast that was Gnome.

9) Printers: Mint found my HP printer and installed it without me even having to do anything at all!

Link to post
Share on other sites

It REALLY, REALLY wants the System 76 5.3 Kernel. I borked the system by going to a regular Mint 5.3 Kernel, and had to do a complete reinstall :angry2: This does not please me. But lesson learned, once it is stable DON'T F**K WITH IT!. Leave well enough alone. Oh, well, back to the salt mines.

Link to post
Share on other sites
  • 2 weeks later...

Battery life is around 4-5 hours. So far I really like this laptop with Mint Linux. I am pretty happy with this laptop so far. The keyboard is great. I am not impressed with the Coreboot firmware though.

Link to post
Share on other sites
I found another issue with the System 76 PPA lashup: Updates are slow to show, really slow. Under just plain Mint it took maybe a minute or two to show an update on the system tray icon. With the System 76 PPAs installed sometimes it is 10 sometimes it is 15 minutes before an update shows. I do not understand why this is happening or what is slowing down the update process. I have noticed this several times now and it seems to be a constant.


Well I am at Barnes and Noble using their WiFi, and multi tasking on the Darter Pro. Battery was fully charged and shows 93% (4:22 hours), with Chromium (10 tabs open), Rhythembox playing, two terminals open (HTOP and another), Thunderbird mail, and three open desktop folders (two from the external drive I have plugged in). Mint and the laptop are handling this with ease. I will be editing a document here real soon, and then we shall see. Power now shows 2:25 (91%) after opening Libre Office writer. So it is fluctuating. Still had that annoying USB port issue on the external drive where I plugged it into the 3.0 port on the right side of the laptop and the laptop did not see the drive. Unplugged it,and put it into a port on the left side and boom! the drive is now seen by MInt. Very odd. The right side USB port sees USB flash drives fine. So I have no idea what is going on with this port.



The laptop is nice and light, the screen is wonderful, and I really like the keyboard for typing, it has excellent key travel. Sound on the headphone jack is nice and clear on my earbuds. So far so good. I hope no one is bored, I'll keep posting the battle reports from this laptop.

Link to post
Share on other sites
  • 3 weeks later...
Well, I am going to close this one down, with the following observation: If I had to do it again, would I do it? That answer is somewhat complicated because of several reasons:


1) I wanted a System 76 device for years.

2) I wanted to support a linux device seller/manufacturer.

3) The hardware specs were good, and allowed me to upgrade the laptop.

4) The screen and keyboard are top notch, no complaints at all.

5) Lightweight, and portable.


Now the no:

1) Coreboot which to me locks you into Pop O/S apparently.

2) Having to use the System 76 PPAs and their GRUB bootloader, and Kernel flavors rather than the regular Mint ones in order to get all the functions of the laptop working such as lighting, WiFi, sound, etc.

3) While upgradable, you have to remove the keyboard to undo three screws to get the back to come loose. This is unacceptable in my world view since the ribbon cables under the keyboard are fragile, and if you are not extremely careful you break the keyboard.

4) System 76 support, which while nice, was of the attitude: "Use our OS or suck it up".

5) Battery life is just meh. 3-5 hours maximun at 30% brightness, and normal usage.


So in retrospective, I might have decided to go with the ProStar variant of this laptop in a clean state with no operating system on board, and regular BIOS/UEFI system.


I would dearly love to hear from others who have System 76 hardware, and their experiences with linux or other operating systems

Link to post
Share on other sites
  • 3 months later...

Well, I have installed Mint 20 WITHOUT the System 76 PPAs and so far it works fine except for a couple of minor issues like the keyboard light. Here is what I have found so far:

 

Hmmm, some issues. It keeps disconnecting from the network. Firefox cannot connect to the network, it shows the network, but no joy. After I installed updates and rebooted, it just shut down. It is a clean installation, wipe and re-install.
Alright after some work, here is how things are going:
1) After two reboots, it suddenly found my wifi card no issues so far.
2) Installed Chrome, not Chromium, but Chrome (I know, I know its Google), no issues so far.
3) Installed VLC, it took a while for the flatpack to download, but it did, and now I have VLC Flatpack.
4) Wonky USB still is wonky, if I plug a usb 3.0 device into the 2.0 port, it will not see the device. At all. However if I put a usb-c dongle onto the USB 3 A drive, and plug it into the USB-C port it works fine! Plus if I have the USB-A 3.0 drive installed in the USB-A 3.0 slot and remove it, I have to reboot to get it to see the drive! Once you remove the drive, apparently the laptop cannot see it again until there is a reboot. Not acceptable.
5) It found my HP printer without me having to do ANYTHING!!!!!
6) Battery life, well we shall see. I have just installed TLP.
7) I have the regular Kernel, not the System 76 special kernels. So I doubt having lights on the keyboard is worth the BS of the PPA so I do not think I will install the System 76 PPA.
8.) Numlock will not operate unless I manually turn it on.
I'll let you all know how Mint 20 works on this laptop. So far things seem ok, but it is early, and I am still installing things, and getting it set up the way I like my computers.
Link to post
Share on other sites
  • 2 months later...

Well. it is going ok, I added the PPAs and now have everything working, but on an odd custom kernel. Battery life SUCKS. Screw fell out of the back, so they are sending me more screws, which is very nice of them. I got weak and ordered their new Lemur Pro 14", which arrived yesterday. Put Mint 20 on it and everything worked. Super lightweight, decent screen, keyboard is not as good as that on the Darter Pro, which is a great keyboard.

Link to post
Share on other sites

Just added a Lemur Pro to the stable. Lupe and the girls gave me my early Christmas present since I have been having a really rough time.  Great Family, I love them, and will show my appreciation for this gift.  Battery life on this thing is INSANE!  It keeps running!

Link to post
Share on other sites
  • 2 weeks later...

Dead system.  DId a BIOS update using their firmware updater, and now my system is dead.  Caught in an endless boot loop where it shows the first System 76 logo, then reboot with an error message that vanishes so quickly I cannot read it.  System 76 sent me an email that they were pushing a BIOS update, and it showed up tonight.  Now I have a dead system.

Link to post
Share on other sites
7 hours ago, Ivanhoe said:

Well, that sucks. Lets hope a bootable flasher can fix it.

 

I hope, I will most likely have to send it in to System 76.  But Lupe has "repurposed" the box, so I will have to improvise.  Here is their email:

 

Quote

Update Now for Open Firmware

 

System76 Open Firmware is now available for Gazelle and Adder WS owners! Updating your firmware brings you fast boot times and increased security. Follow the link below for instructions on how to update.

If you're using the Darter Pro, your computer will automatically update to receive open source System76 Embedded Controller Firmware. This gives you access to important functionality, such as your keyboard, fans, and battery.

 

Link to post
Share on other sites

I received a personal phone call from System 76 apologizing for the issue, and telling me that it can be fixed.  I am really impressed.  It was their firmware, and they will stand up and take care of it.  Highly impressed.  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...